Bahnübergänge Kyffhäuserkreis

    • Behoben
    • Routing
    • Serhan wrote:

      Bitte Links wie in diesem Post beschrieben erstellen, damit man das überhaupt nachvollziehen und vergleichen kann.
      Brauche ich nicht, habe den Fehler gefunden. Es liegt an den Bahnübergängen, welche er nicht überqueren möchte. Ich kann aber leider auch nicht jede Barrier entfernen um über die Bahnübergänge zu kommen. Hat jemand eine Idee? Kommt das dann auch ins Spiel, Serhan?
      Avatar: RK Wernshausen 83/1
      (Blanko: Chr2, Westfale und RedNavy)
      Grafikwünsche von Usern

      The post was edited 3 times, last by RedNavy ().

    • RedNavy wrote:

      Es liegt an den Bahnübergängen, welche er nicht überqueren möchte. Ich kann aber leider auch nicht jede Barrier entfernen um über die Bahnübergänge zu kommen. Hat jemand eine Idee? Kommt das dann auch ins Spiel, Serhan?

      Was meinst du mit Barriere entfernen? Bei OpenStreetMap direkt? Ist es denn dort falsch abgespeichert?

      Wann ich die Routingdaten aktualisiere, kann ich momentan noch nicht sagen, da ich erst noch ausprobieren muss, ob der gleichzeitige Betrieb und Import des Routings auf dem gleichen Server möglich ist.

      (Geocoding-Updates werden laufend eingespielt, momentan gibt es hier eine Verzögerung von 8 Tagen. Der Server muss die Differenz erst noch aufholen, was noch die ein oder andere Woche dauern wird.)
    • Also Serhan, ich hole mal etwas weiter aus. Ich habe mir die betreffende Strecke angeschaut (die Grüne). Dort sind zwei Bahnübergänge. Wenn ich die grüne Strecke nun auf map.project-osrm.org einzeichnen will, geht das nicht. Warum? Weil er diese zwei Bahnübergänge nicht überfahren will.

      Das siehst du auch hier: map.project.osrm.org

      Wenn du nun den roten Marker nach unten ziehst, merkst du das er eine andere Route sucht, statt über den Bahnübergang zu fahren. Nun habe ich mich an OSM rangesetzt und habe mir das im Editor von OSM mal angeschaut. Dort ist etwas von barrier, full-barrier usw. angegeben. Bei einem vergleichbaren Bahnübergang in Thüringen sind diese nicht zu finden - und dort lässt sich die Route auch über den Bahnübergang führen. Siehe hier: map.project-osrm.org.

      Auf dem vergleichbaren Bahnübergang (siehe letzter Link) steht nichts von barrier oder ähnlichem. Deswegen geht es dort auch. Nun bin ich mir aber unsicher ob ich die barrier`s entfernen soll, oder nicht. Darum geht es mir, ist das vl. anders lösbar? Ich hoffe du weißt was ich meine. ;)

      Gruß RedNavy
      Avatar: RK Wernshausen 83/1
      (Blanko: Chr2, Westfale und RedNavy)
      Grafikwünsche von Usern
    • Ich habe mir den Übergang mal angesehen: normalerweise gibt es eine Vorlage im Editor, mit dem Bahnübergänge noch weiter beschrieben werden können, also ob es Schranken gibt, und wenn ja, welcher Art, einen Gong, Ampeln, etc. Diese Daten werden zum Beispiel genutzt, um eine sicherere Navigation für Blinde zu erarbeiten.

      Im konkreten Fall ist das aber falsch gemacht worden, der Bearbeiter wollte sagen, dass es Schranken gibt, hat aber nicht die Vorlage benutzt, sondern die Werte frei Hand eingetragen, unter anderem barrier=yes, was OSM aber als eine Barriere im Sinne eines Pollers oder einer Kette interpretiert, und nicht als Schranke.

      The post was edited 2 times, last by Todeskuh ().

    • Danke für die Ausführungen. ;) Wie du sagst, hat die betroffene Stelle barrier=yes und half_barrier=yes als Eigenschaften. Auf der Erklärseite für key:barrier suggeriert aber nichts, dass diese Eigenschaften für Schranken bei Bahnübergängen verwendet werden.

      Stattdessen habe ich Tag:railway=level_crossing und Key:crossing:barrier gefunden. Diese Eigenschaften werden z. B. bei diesem Bahnübergang verwendet (OSM-Link, Google-Maps-Link). Die Routenführung scheint hier problemlos zu klappen. Aus dem Grund denke ich, dass auch die Routenführung an der problematischen Stelle wieder klappen sollte, wenn dort ein crossing:barrier verwendet wird.

      Wann die Änderung dann auch in LstSim aktiv wird, hängt wie gesagt davon ab, wann eine neue planet.pbf mit der Änderung verfügbar ist und ob der Reimport auf dem jetzigen Produktivserver nebenher klappt. ;)
    • Abend an alle,

      Nachdem Serhan nun die Daten neu eingespielt hat, habe ich versucht den betroffenen RTW über die alte Strecke zu leiten (siehe erster Post). Er zeigt nun immer ein kleines Fenster an in dem steht: "Fehler bei der Zielroutenfindung. Benutze ausnahmsweiße Luftlinie". Serhan, an was könnte das denn liegen?

      Gruß RedNavy
      Avatar: RK Wernshausen 83/1
      (Blanko: Chr2, Westfale und RedNavy)
      Grafikwünsche von Usern
    • Hm, bei mir wir die ehemals problematische Stelle korrekt befahren. Ich hatte vorhin nochmal den Routingserver neugestartet, kann aber nicht sagen, ob es damit wirklich zu tun hatte. Zumal das Spiel im Fehlerfall automatisch auf den Demoserver wechselt. Tritt das Problem jetzt immer noch auf? Auch in einem anderen Browser? Ist deine Internetverbindung stabil?
    • Serhan, ich habe es nochmal im Chrome (mein Standardbrowser) und im neuen MS Edge getestet. Es läuft jetzt. Scheint wohl am Neustart gelegen zu haben. Bin dir sehr dankbar, und wer weiß, vl. bekommst du es auch noch hin die Karte auf OSM zu stellen. Aber vorerst, sehr schön. Ehrlich, es sei dir gesagt, auch für deine stetige Kommunikation in den letzten Tagen, Wochen, ein ganz großes und dickes Danke dafür! Endlich wieder das spielen genießen...... *Glücklich in Gedanken versunken*
      Avatar: RK Wernshausen 83/1
      (Blanko: Chr2, Westfale und RedNavy)
      Grafikwünsche von Usern
    • RedNavy wrote:

      Ehrlich, es sei dir gesagt, auch für deine stetige Kommunikation in den letzten Tagen, Wochen, ein ganz großes und dickes Danke dafür! Endlich wieder das spielen genießen...... *Glücklich in Gedanken versunken*
      Dem kann ich mich nur anschließen! :thumbsup: